Uputstvo za integraciju ERP PANTHEON 5.5. i FP Hybrid

Uputstvo za integraciju ERP PANTHEON-a 55 sa fiskalnim štampačem Hybrid
Nakon uspješno završene integracije ERP PANTHEON-a 55 sa fiskalnim štampačem Hybrid, firme Mikroelektronika a.d., Banjaluka
, te više nivoa testiranja, pred Vama je uputstvo za podešavanja integracije ERP PANTHEON-a 55 sa fiskalnim štampačem
Hybrid. Sva podešavanja možete izvršiti u samo nekoliko koraka, i u veoma kratkom vremenu imati gotovo rješenje i PANTHEON
spreman za rad sa fiskalnim štampačem Hybrid i tako izvršiti obavezu fiskalizacije veleprodaje.
Podešavanjima se pristupa u modulu Roba, zatim Izdavanje, Dokument i na kraju dokument 300 - Veleprodaja .

Nakon toga otvara Vam se prozor za Veleprodaju, gdje pritiskom na tipku čarobnjak otvori se meni, sa kojeg izaberete opciju Postavke

fiskalnog štampača .

Lijevim klikom miša na opciju Postavke fiskalnog štampača otvara vam se prozor sa postavkama, gdje označite opciju Upotreba fiskalnog

printera, na ovom prozoru u polju Fiskalni printer izaberete za fiskalni štampač Hybrid opciju "Korisnička podešavanja" ili

"Mikroelektronika Hybrid". Prva opcija Korisnička podešavanja je vezana za integraciju FP Hybrid koja je napravljena

preko korisničkog dpa, koji je neophodno prije nego se odabere ova opcija učitati u Pantheon prema uputstvu sa stranice DPA AFISKVP

HYBRID iz ovog uputstva, ovaj vid integracije je više namijenjen korisnicima koji žele dodatne izmjene na već postojećoj integraciji (uvođenje

dodatnih funkcija, prilagođavanje svojim potrebama i sl.), druga opcija Mikroelektronika Hybrid označava "sistemsku" integraciju, tj. integraciju

urađenu direktno u Pantheonu bez potrebe za učitvanjem prethodno spomenutog dpa.

Nakon prethodno odabrane vrste integracije, treba izvršiti sljedeća podešavanja:

U polju Direktorij Print upišete putanju do direktorija gdje šaljete račune na ispis za fiskalni štampač, zadano za fiskalni driver Flink H (HP)

to je c:\temp, te putanju do direktorija za smještanje log datoteka, također zadano to je c:\temp, u polje tekst za kupca upišete tekst

koji želite da se ispisuje na dnu računa u reklamne svrhe i sl. i pritisnete tipku Tekst za kupca, tom prilikom program će vas upitati "Da li da

promijenim tekst za kupca na fiskalnom printeru" potvrdite i time ste izmijenili tekst za kupca u fiskalnom štampaču.

Opciju Numeričke PLU šifre označite ukoliko želite koristiti PLU šifre, ili pak odznačite ukoliko ćete koristiti alfanumeričke - Pantheon šifre,

ovo polje je opciono i prema vašim zahtjevima možete koristiti u svom radu, PLU šifre ili pak Pantheon šifre (rad fiskalnog štampača je brži sa

plu šiframa).

Na desnoj strani su dodatne opcije kao što su podešavanje ljetnog i zimskog vremena na štampaču, te tekst za kupca i naziv trgovine, opcija

popuni sve artikle ne koristi se kod fiskalnog štampača Hybrid.


DPA AFISKVP Hybrid

Prije nego se pristupi ostalim podešavanjima za integraciju Pantheona sa FP Hybrid preko opcije "korisnička podešavanja" na panelu postavke fiskalnog štampača

na čarobnjaku dokumenta 300 , neophodno je uvesti (import) u PANTHEON-u dpa koji je napravljen za integraciju sa fiskalnim štampačem Hybrid, namijenjenu

korisnicima koji žele uvoditi dodatne funkcije i sl. , ovaj dpa je neophodno učitati samo za opciju korisnička podešavanja iz postavki, ne i za opciju Mikroelektronika

Hybrid.

Sve što je potrebno uraditi je pristupiti ARESU, preko menija Postavke/Program/Ares , kao što je prikazano na slici,

zatim, na novootvorenom prozoru Aresa, uvesti dpa AFISVP Hybrid, (koji ste prethodno preuzeli sa naše stranice, dpa možete direktno preuzeti sa ove lokacije

AFISKVP Hybrid ) klikom na meni Sadržaj/Datoteka, pa Uvoz iz datoteke.

I učitate ga sa lokacije na vašem disku, gdje ste ga prethodno smjestili.

Nakon učitavanja dpa AFISKVP HYBRID, sa desne strane ćete vidjeti učitani dpa, potrebno je kliknuti na tipku Prevedi - crveni uskličnik , koja se nalazi na traci sa alatima, ili joj možete pristupiti preko menija Sadržaj, pa zatim Start/Prevedi ili kraticom CTRL+F9

Nakon što je preveden DPA, na dnu otvorenog prozora ispisaće se poruka "Program je uspješno preveden", time ste uspješno učitali i preveli DPA u PANTHEON i možete zatvoriti ovaj prozor i preći na ostala podešavanja na dokumentu 300, zatim lijevim ili desnom klikom miša na čarobnjak na dokumentu 300 otvorite meni sa njega odaberete Postavke fiskalnog štampača i nastavite sa podešavanjima koja su spomenuta na prvoj stranici ovog uputstva.


Izvještaji, dodatne funkcije
Na meniju čarobnjaka

, pronaći ćete dodatne funkcije kao što su ispis računa na fiskalnom štampaču, stavljanje i uzimanje depozita, te izvještaje kao što su

Presjek stanja - X izvještaj, Zaključi fiskalni printer - Z izvještaj, i Periodični izvještaj od - do. Također na meniju čarobnjaka smještena je i funkcija storno

računa, odnosno, veleprodajni reklamirani račun.


PLU šifre, IBK

PLU šifre se unose u šifrantu artikala na označenom polju

Kako je obaveza ispisa IBK na računu, odnosno JIB klijenta, potrebno je u šifrantu subjekata unijeti JIB za svog klijenta iz BiH, i tako će se on prilikom odabira kupca na dokumentu 300, direktno slati na računu za ispis - IBK (Identifikacioni broj klijenta).

Ukoliko se radi o kupcu iz inostranstva - izvoz (način prodaje-izvoz), tada će se za JIB broj iz Panteona slati 2-slovna oznaka zemlje prema ASYCUDA, koja će se puniti iz šifranta država - kolona prefix.por.br. , i ostatak JIB-a za inostranog kupca (prema Pravilniku o Fiskalizaciji PURS, proizvoljna jedinstvena šifra klijenta), tih preostalih 11 brojeva, puni će se iz PIB-a, i ukoliko je PIB veći od 11 brojeva, Pantheon će sijeći PIB na 11, kako bi se FP Hybrid poslao IBK od 13 karaktera.

2-slovna oznaka zemlje prema ASYCUDA (http://www.poreskaupravars.org/dokumenti/sifarnik_zemalja.xls) + 11 brojeva = IBK za inostrance kupce.

Tako da kada u PA izaberete način prodaje izvoz, tj. prodajete stranom kupcu, IBK za tog kupca će se slati na način kao sto je prethodno opisano, bez upisivanja JIB u šifrantu subjekata.

Na slici ispod imate primjer kako izgeda jedan Veleprodajni račun spreman za slanje na fiskalni štampač Hybrid.

PLU šifra.


Veleprodajni fiskalni račun

Pored ispisa veleprodajnog fiskalnog računa, u PANTHEON-u je i dalje moguće ispis računa na A4 printer, kao što je to i prije integracije

fiskalnog printera bilo moguće, a da se pri tome dokument ne potvrdi, dokument se potvrdi, kada se račun pošalje na fiskalni printer.

Kako bi ovo bilo moguće, neophodno je da u Šifrantu vrsta dokumenata, kojemu pristupate na sljedeći način

Te kako izgleda veleprodajni fiskalni račun i veleprodajni reklamirani račun ispisani na FP Hybrid.

pa za dokumen 300 odznačite opciju "Potvrdi dokument kod ispisa" i na taj način biće omogućeno potvrđivanje dokumenta tek nakon ispisa na fiskalni štampač Hybrid.


Elementi veleprodajnog fiskalnog računa

Kod plaćanja u zavisnosti, da li se plaća gotovinom, kreditnom karticom, virmanom, sa padajućeg

Veoma bitni elementi koje treba da sadrži račun koji se šalje na ispis na fiskalni štampač su Naziv kupca - klijenta, adresa kupca - sjedište kupca - klijenta, telefon kupca - klijenta, IBK broj - JIB. Ukoliko je kupac iz BiH, onda se na računu ispisuje za IBK broj JIB kupca unešen u šifrantu subjekata, dok je to za inostranog kupca 2 slovna oznaka zemlje - prva dva znaka iz ASYCUDA , prema pravilniku o Fiskalizaciji PURS i nakon toga proizvoljna šifra za klijenta, u Pantheonu se ova proizvoljna šifra nakon 2-slovne oznake dodaje iz PIB , i tako se kreira jedinstveni IBK za inostranog kupca.

menija “Načini plaćanja, na dokumentu Veleprodaja - 300

označite vrstu plaćanja kojom se izvršava plaćanje.

(Iako za FP Hybrid nije neophodno slanje vrste plaćanja i iznos računa, stoga će se u datoteci za ispis slati samo količina i cijena, a FP Hybrid će na osnovu njih

izračunati total računa, naravno ovo je samo vezano za FP Hybrid, ne i za rad u Pantheonu, Pantheon funkcioniše kao i prije na dokumentu 300, a ovo

se odnosi samo na datoteku koja se šalje na ispis, i na ovaj način neće dolaziti do nekih manjih odstupanja poput 0.01 KM, zbog načina zaokruživanja FP Hybrid

, kao što je to bilo u fiskalizaciji maloprodaje.)

Ukoliko određeni način plaćanja nije na listi, to podešavanje izvršite u šifrantu „
Načini plaćanja ", koji se nalazi na
sljedećoj lokaciji,
gdje za „Slip tip
“, kod gotovine označite – 0, kod
čeka – 1, kod kartice – 2, kod virmana-3. Za vrstu kod svih načina plaćanja postavite G-gotovina.


Veleprodajni reklamirani fiskalni račun

Storno veleprodajnog fiskalnog računa

Storno veleprodajnog fiskalnog računa, odnosno veleprodajni reklamirani račun izvršavamo na sljedeći način. Ukoliko želimo prethodno ispisani veleprodajni fiskalni račun 09-300-000072

to ćemo učiniti tako što, otvorimo novi račun, i u polje Kupac dodamo kupca - klijenta koji reklamira svoj veleprodajni fiskalni račun, u ovom slučaju je to Kupac d.o.o i označimo način plaćanja kojim je izvršen prethodno veleprodajni fiskalni račun, zatim na tipku potvrdi, potvrdimo taj unos, kao na slici ispod.

Sljedeći korak je dodavanje pozicija s računa koji se želi reklamirati, a to je dodavanje pozicija dokumenta 09-300-000047, to uradimo pritiskom na tipku Dodaj na panelu Pozicije kao na slici. Nakon toga se otvara prozor Dodavanje prometa na dostavnicu, gdje označena polja popunimo kao što je prikazano na slici, u polju Dokument označite dokument koji stornirate, to je u ovom slučaju 09-300-000047 i označite polje Zamijeni predznak (storno dokumenta) i klikom na tipku dodaj na panelu Pozicije za prenos izvršite dodavanje pozicija na novokreirani dokument 09-300-000048 kojim ćete stornirati prethodni račun 09-300-000047.

Program će vas obavijestiti da je dodavanje zaključeno i onda možete zatvoriti prozor za Dodavanje prometa.

Na novootovrenom dokumentu - računu, sada ćete vidjeti pozicije koje su uspješno prenesene sa dokumenta koji se želi stornirati, i biće sa negativnim predznakom.

Sljedeći korak je da na meniju čarobnjaka lijevom tipkom miša kliknete na opciju Storno fiskalnog računa

Otvara se novi prozor, gdje upisujete Broj fiskalnog računa (koji ćete pronaći na ispisanom veleprodajnom računu) i broj Pantheon računa koji ćete također pronaći ispisan na veleprodajnom fiskalnom računu ili pak direktno iz Pantheona ga pročitate.

Pritiskom na tipku Pošalji, pošaljete na ispis veleprodajni reklamirani račun, program će vas pri tome upitati "Da li stvarno želite da nastavite", pritiskom na tipku Potvrdi nastavite dalje i posljednji korak je lijevim klikom miša pritisnuti na tipku FP i time direktno ispišete veleprodajni reklamirani račun na fiskalni štampač Hybird.

Račun se potvrdi i time je izvršen veleprodajni reklamirani račun kao na slici ispod


Zaokruživanja

Zbog zahtjeva F-linka HP za zaokruživanjem izračuna cijena na 2 decimale, neophodno je ovome prilagoditi i PANTHEON, kako ne bi dolazilo do toga da

total plaćanja nije isti kao što štampač zaokružuje, i onda se dešava da račun ostaje otvoren i čekaće na uplatu dodatnih 0.01 KM ili slično.

Ovo se dešava ukoliko u Administratorskoj konzoli u postavkama za Preduzeće\Zaokruživanje imate postavljeno zaokruživanje izračuna cijene na 4 decimale-prva postavka.

Na ovaj način bi trebalo biti podešeno zaokruživanje u AK \Postavke\Parametri programa\Preduzeće\Zaokruživanje

Postavke zaokruživanja zapisuju se u glavi dokumenta tako da ako testirate na jednom već otvorenom računu i promijenite postavke zaokruživanja, na istom

dokumentu će važiti stare postavke, tako da je potrebno otvoriti novi da bi vidjeli promjene.


Napomene

.
*Na kraju nekoliko napomena:
Zbog načina rada F-linka HP i FP Hybrid , u PANTHEON-u je urađeno takvo rješenje da se naziv artikla koji se šalje iz Pantheona na fiskalni štampač za veleprodaju
sastoji samo iz naziva artikla + /JM, bez slanja kombinacije šifra+naziv, jer za FP Hybrid jednoznačnost naziva artikla koji se šalje na ispis nije bitna.

Naziv artikla za FP Hybrid je maksimalne dužine 30 znakova, i Pantheon siječe naziv artikla na 30 znakova, ukoliko je dužina naziva artikla koji se šalje na FP Hybrid

veća od 30 znakova (naziv artikla za FP Hybrid = 27 znakova naziva artikla iz Pantheona + 3 znaka /JM = 30 znakova).

To bi na primjeru jednog artikla sa nazivom koji sadrži više od 30 znakova, ovako izgledalo:

Ukoliko je Naziv artikla: ¨sok cappy juice 2L mix vitaminski 2l pakovanje¨ i prodajemo 2L ovog artikla, to će na ispisu računa biti u ovom formatu

sok cappy juice 2L mix vita/L.

Znači makimalan broj karaktera koji se ispisuje na računu i dalje ostaje 27 , zbog F-linka HP i veleprodaje, jer on prima maksimalno 30 karaktera.
27+/JM (/jedinica mjere – 3 znaka) ! FP Hybrid također bi ovo i samostalno radio ukoliko mu se pošalje naziv duži od 30 znakova, on bi ga sijekao na 30 znakova.


Flink HP

Za podešvanja F-linka HP, odnosno Flink-H na raspolaganju Vam je uputstvo na sljedećoj lokaciji,

http://www.mikroelektronika.net/download/ME-flink-hp.zip

http://www.mikroelektronika.net/download/ME-flink-h.zip

Zadnja verzija pomoćnog programa PGM, uključena je u F-link HP (H) instalaciji!

ili se pak obratite fiskalnim distributerima firme Mikroelektronika za detaljnija uputstva.


Ispis broja fiskalnog računa na računima iz Pantheona

Zakonom o fiskalizaciji u RS, pored ispisa broja fiskalnog/reklamiranog računa na fiskalnom štampaču, obaveza je da se i brojevi fiskalnih/reklamiranih računa nalaze na fakturama koje se štampaju iz nadređenog programa.

Iz ovog razloga je uvedena nova funkcionalnost u Pantheonu da se broj fiskalnog računa pojavljuje i na fakturama, nakon ispisa fiskalnog/reklamiranog računa, kada štampač pošalje informaciju - odgovor o broju fiskalnog/reklamiranog računa.

Da bi ovo bilo moguće trebate izvršiti dodatna podešavanja, u Pantheonu su uvedena sistemski 2 nova dataseta (acFiskPrintNo i acFiskPrintNoS), koje je potrebno postaviti na ispisu gdje želite da vam se pojavljuje informacija o broju fiskalnog računa prethodno ispisanog na fiskalnom štampaču.

To radite na sljedeći način (ovo podešavanje je isto za oba fiskalna štampača za VP), otvorite određeni korisnički ispis, postavite se na poziciju gdje želite da vam se pojavljuje informacija o broju fiskalnog/reklamiranog računa i na toj poziciji postavite 2 nova dataseta prethodno spomenuta.

Na vašem ispisu pritisnete na predpregledu ispisa na tipku oblikuj kao na slici ispod i oblikujete ispis prema vašim potrebama u ovom slučaju dodavanje datasetova za prikaz broja fisk./reklam. računa.

Nakon toga otvaram vam se prozor za oblikovanje ispisa, na kojem sa menija view\toolbars odaberete alat Data Tree sa kojeg dodajete željeni dataset na ispisu,

nakon što kliknete na data tree otvoriće vam se prozor na kojem ćete pronaći datasetove acFiskPrintNo i acFiskPrintNoS pod qReportIzpisD, kao što je prikazano na slici ispod.

Jednostavnim povlačenjem (drag & drop) ova 2 dataseta postavite na poziciji gdje želite da vam se pojavljuju brojevi fiskalnih računa,

u ovom primjeru to je ispod polja Dostava i Odgovorna osoba kao na slici ispod

na ispisu to će izgledati ovako, broj fiskalnog / reklamiranog računa pojaviće se ispod Dostava i Odgovorna osoba kako smo to i u oblikovanju ispisa postavili.


Page0003

Na panelu
POS printer
nisu potrebna dodatna podešavanja, pored zadanih.
Na panelu
Prikazni ekran (display),
nisu potrebna dodatna podešavanja, pored zadanih.
Na panelu Fiskalni printer, neophodno je izvršiti sljedeća podešavanja, označiti opciju
„Upotreba fiskalnog printera“,
sa padajućeg menija
Fiskalni printer
, odabrati


Page0004

„

Na panelu Fiskalni printer, neophodno je izvršiti sljedeća podešavanja, označiti opciju

"Mikroelektronika professional
“, te pored navedenog označiti putanju direktorija za print u
folder
C:\temp
i putanju direktorija za log „
C:\temp" “,to je
folder gdje se šalju file-ovi za
printanje i gdje se smještaju log file-ovi. Dodatna podešavanja kao što su
podešavanje prelaska
na ljetno ili zimsko računanje vremena, poreske stope, jedinice mjere, tekst za kupca i naziv trgovine , možete
izvršiti sa tipkama koje se nalaze desno na ovom prozoru.
Opciono možete izabrati upotrebu numeričkih PLU šifri
u zavisnosti od vaših potreba, ukoliko

ova opcija nije uključena, koriste se alfanumeričke šifre, odnosno šifre iz PANTHEON-a.


Page0010

Kao i što je prethodno navedeno u PANTHEON-u je omogućen rad kako sa PLU šiframa (numeričkim), tako i sa PA šiframa

(alfanumeričkim), kako to izgleda u fiskalnom printeru (memoriji fiskalnog printera) - unos ovih artikala, prikazano je na slici ispod:
Artikli sa
PLU šiframa (numeričkim)
Artikli sa
PA šiframa (alfanumeričkim)
Rad sa plu šiframa je brži u odnosu na rad sa pa šiframa, što je jedna od prednosti korištenja plu šifara, koje unosite
u šifrant artikala u polje predviđeno za plu šifre, mada je na korisniku da odluči koje će šifre koristiti u svom radu.