Page0001

Uputstvo za integraciju ERP PANTHEON-a 55 sa fiskalnim štampačem Hybrid
Nakon uspješno završene integracije ERP PANTHEON-a 55 sa fiskalnim štampačem Hybrid firme Mikroelektronika a.d.,
Banjaluka , te više nivoa testiranja, pred Vama je uputstvo za podešavanja integracije ERP PANTHEON-a 55 sa fiskalnim štampačem
Hybrid. Sva podešavanja možete izvršiti u samo nekoliko koraka, i u veoma kratkom vremenu imati gotovo rješenje i PANTHEON
spreman za rad sa fiskalnim printerom Hybrid i tako izvršiti obavezu fiskalizacije veleprodaje.
Podešavanjima se pristupa u modulu Roba, zatim Izdavanje, Dokument i na kraju dokument 300 - Veleprodaja .

Nakon toga otvara Vam se prozor za Veleprodaju, gdje pritiskom na tipku čarobnjak otvori se meni, sa kojeg izaberete opciju Postavke

fiskalnog štampača .

Lijevim klikom miša na opciju Postavke fiskalnog štampača otvara vam se prozor sa postavkama, gdje označite opciju Upotreba fiskalnog

printera, na ovom prozoru u polju Fiskalni printer izaberete za fiskalni štampač Hybrid opciju "Korisnička podešavanja".

U polju Direktorij Print upišete putanju do direktorija gdje šaljete račune na ispis za fiskalni printer, zadano za fiskalni driver Flink H (HP)

to je c:\temp, te putanju do direktorija za smještanje log datoteka, također zadano to je c:\temp, u polje tekst za kupca upišete tekst

koji želite da se ispisuje na dnu računa u reklamne svrhe i sl.

Opciju Numeričke PLU šifre označite ukoliko želite koristiti PLU šifre, ili pak odznačite ukoliko ćete koristiti alfanumeričke - Pantheon šifre,

ovo polje je opciono i prema vašim zahtjevima možete koristiti u svom radu, PLU šifre ili pak Pantheon šifre.

Na desnoj strani su dodatne opcije kao što su podešavanje ljetnog i zimskog vremena na štampaču, te tekst za kupca i naziv trgovine, opcija

popuni sve artikle ne koristi se kod fiskalnog štampača Hybrid.


Page0002

Na meniju čarobnjaka

, pronaći ćete dodatne funkcije kao što su ispis računa na fiskalni printer, stavljanje i uzimanje depozita, te izvještaje kao što su Presjek

presjek stanja - X izvjestaj, Zaključi fiskalni printer - Z izvještaj, i Periodični izvještaj. Također na meniju čarobnjaka smještena je i funkcija storno računa,
odnosno, veleprodajni reklamirani račun.


Page0005

PLU šifre se unose u šifrantu artikala na označenom polju

Na slici ispod imate primjer kako izgeda jedan Veleprodajni račun spreman za slanje na fiskalni printer.

PLU šifra.


Page0004

Pored ispisa veleprodajnog fiskalnog računa, u PANTHEON-u je i dalje mogu i ispis računa na A4 printer, kao što je to

i prije integracije fiskalnog printera bilo moguće, a da se pri tome dokument ne potvrdi, dokument se potvrdi, kada se

račun pošalje na fiskalni printer.

Kako bi ovo bilo moguće, neophodno je da u Šifrantu vrsta dokumenata, kojemu pristupate na sljedeći način

odznačite opciju "Potvrdi dokument kod ispisa" i na taj način biće omogućeno potvrđivanje dokumenta nakon ispisa na fiskalni štampač Hybrid.


Page0005

Kod plaćanja u ovisnosti, da li se plaća gotovinom, kreditnom karticom, vrimanom, sa padajućeg

Veoma bitni elementi koje treba da sadrži račun koji se šalje na ispis na fiskalni štampač su Naziv kupca - klijenta, adresa kupca - sjedište kupca - klijenta, telefon kupca - klijenta, IBK broj - PIB. Ukoliko je kupac iz BiH, onda se na računu ne ispisuje uz PIB oznaka za valutu KM, ako je u pitanju kupac izvoz - inostranstvo tada se prema pravilniku o Fiskalizaciji PURS uz IBK broj dodaje 2-znakovna oznaka inostrane zemlje, što je i implementirano u Pantheonu, tako se kod ispisa računa za kupca iz BiH ne ispisuje KM.

menija
“Načini plaćanja, na dokumentu Veleprodaja - 300 označite vrstu plaćanja kojom se izvršava plaćanje.
Ukoliko određeni način plaćanja nije na listi, to podešavanje izvršite u šifrantu „
Načini plaćanja ", koji se nalazi na
sljedećoj lokaciji,
gdje za „Slip tip
“,kod gotovine označite – 0, kod
čeka – 1, kod kartice – 2, kod virmana-3.


Page0006

.
*Na kraju nekoliko napomena:
Zbog načina rada F-linka H i obaveze jedinstvenih (unique) naziva u pomoćnom programu PGM-u,
odnosno u memoriji fiskalnog printera, u PANTHEON-u je urađeno takvo rješenje da se naziv
artikla u memoriji fiskalnog printera, sastoji od: ¨šifra artikla_naziv artikla¨ (PANTHEON siječe
sa desne strane višak) , znači šifra artikla+naziv artikla i onda PANTHEON siječe sa desne strane
na 29 znakova, jer je maksimalan broj karaktera naziva artikla u F-linku 32 karaktera, što je u
ovom slučaju naziv artikla – 29 karaktera + 3 karaktera
/JM
(jedinica mjere) = 32 karaktera.
To bi na primjeru jednog artikla sa dužim nazivom, ovako izgledalo:
Ukoliko je Naziv artikla: ¨sok cappy juice 2L mix vitaminski 2l pakovanje¨ , a njegova PA šifra
“1234567890123456” (max. dužina šifre)
Njega PANTHEON siječe na ¨1234567890123456_sok cappy ju¨
Ovdje je riječ ukoliko je dužina šifre 16 karaktera (maksimalni broj karaktera za šifru), ovime se rješava
problem sa istim nazivima u F-linku H koje on ne prima i napravi korisnicima zbog toga problem.
Znači makimalan broj karaktera koji se ispisuje na računu i dalje ostaje 29 , zbog F-linka H, jer on prima 32,
29+/JM (jedinica mjere – 2 znaka) !
Ovime se rješava problem istih naziva u fiskalnom printeru, koji je mogući, zbog artikala sa dužim
nazivima, do 40 znakova, a tipa od 25-og do 29-og znaka, ponavljaju im se ti dijelovi naziva tipa
cappy juice 2L mix vitaminski 2l pakovanje
cappy juice 2L mix vitaminski 3l pakovanje


Page0007

Storno veleprodajnog fiskalnog računa

Storno veleprodajnog fiskalnog računa, odnosno veleprodajni reklamirani račun izvršavamo na sljedeći način. Ukoliko želimo prethodno ispisani veleprodajni fiskalni račun 09-300-000047

to ćemo učiniti tako što, otvorimo novi račun, i u polje Kupac dodamo kupca - klijenta koji reklamira svoj veleprodajni fiskalni račun, u ovom slučaju je to Kupac d.o.o i označimo način plaćanja kojim je izvršen prethodno veleprodajni fiskalni račun, zatim na tipku potvrdi, potvrdimo taj unos u polje kupac, kao na slici ispod.

Sljedeći korak je dodavanje pozicija s računa koji se želi reklamirati, a to je dodavanje pozicija dokumenta 09-300-000047, to uradimo pritiskom na tipku Dodaj na panelu Pozicije kao na slici. Nakon toga se otvara prozor Dodavanje prometa na dostavnicu, gdje označena polja popunimo kao što je prikazano na slici, u polju Dokument označite dokument koji stornirate, to je u ovom slučaju 09-300-000047 i označite polje Zamijeni predznak (storno dokumenta) i klikom na tipku dodaj na panelu Pozicije za prenos izvršite dodavanje pozicija na novokreirani dokument 09-300-000048 kojim ćete stornirati prethodni račun 09-300-000047.

Program će vas obavijestiti da je dodavanje zaključeno i onda možete zatvoriti prozor za Dodavanje prometa.

Na novootovrenom dokumentu - računu, sada ćete vidjeti pozicije koje su uspješno prenesene sa dokumenta koji se želi stornirati, i biće sa negativnim predznakom.

Sljedeći korak je da na meniju čarobnjaka lijevom tipkom miša kliknete na opciju Storno fiskalnog računa

Otvara se novi prozor, gdje upisujete Broj fiskalnog računa (koji ćete pronaći na ispisanom veleprodajnom računu) i broj Pantheon računa koji ćete također pronaći ispisan na veleprodajnom fiskalnom računu ili pak direktno iz Pantheona ga pročitate.

Pritiskom na tipku Pošalji, pošaljete na ispis veleprodajni reklamirani račun, program će vas pri tome upitati "Da li stvarno želite da nastavite", pritiskom na tipku Potvrdi nastavite dalje i posljednji korak je lijevim klikom miša pritisnuti na tipku FP i time direktno ispišete veleprodajni reklamirani račun na fiskalni štampač Hybird.

Račun se potvrdi i time je izvršen veleprodajni reklamirani račun kao na slici ispod


Page0008

Zbog zahtjeva F-linka H za zaokruživanjem izračuna cijena na 2 decimale, neophodno je ovome prilagoditi i PANTHEON, kako ne bi dolazilo do toga da

total plaćanja nije isti kao što printer zaokružuje, i onda se dešava da račun ostaje otvoren i čekaće na uplatu dodatnih 0.01 ili slično KM.

Ovo se dešava ukoliko u Administratorskoj konzoli u postavkama za Preduzeće\Zaokruživanje imate postavljeno zaokruživanje izračuna cijene na 4 decimale-prva postavka.

Na ovaj način bi trebalo biti podešeno zaokruživanje u AK \Postavke\Parametri programa\Preduzeće\Zaokruživanje

Postavke zaokruživanja zapisuju se u glavu dokumenta tako da ako testirate na jednom već otvorenom računu i promijenite postavke zaokruživanja, na istom

Dokumentu će važiti stare postavke, tako da je potrebno otvoriti novi da bi vidjeli promjene.


Page0010

Kao i što je prethodno navedeno u PANTHEON-u je omogućen rad kako sa PLU šiframa (numeričkim), tako i sa PA šiframa

(alfanumeričkim), kako to izgleda u fiskalnom printeru (memoriji fiskalnog printera) - unos ovih artikala, prikazano je na slici ispod:
Artikli sa
PLU šiframa (numeričkim)
Artikli sa
PA šiframa (alfanumeričkim)
Rad sa plu šiframa je brži u odnosu na rad sa pa šiframa, što je jedna od prednosti korištenja plu šifara, koje unosite
u šifrant artikala u polje predviđeno za plu šifre, mada je na korisniku da odluči koje će šifre koristiti u svom radu.


Page0010

Za podešvanja F-linka H na raspolaganju Vam je uputstvo na sljedećoj lokaciji,
http://www.mikroelektronika.net/download/ME-flink-h.zip

te zadnja verzija pomoćnog programa PGM, koju uz konsultaciju fiskalnih distributera

instalirajte uz F-link H instalaciju!

http://www.mikroelektronika.net/index.php?data=081124

ili se pak obratite fiskalnim distributerima firme Mikroelektronika za detaljnija uputstva.


Page0003

Na panelu
POS printer
nisu potrebna dodatna podešavanja, pored zadanih.
Na panelu
Prikazni ekran (display),
nisu potrebna dodatna podešavanja, pored zadanih.
Na panelu Fiskalni printer, neophodno je izvršiti sljedeća podešavanja, označiti opciju
„Upotreba fiskalnog printera“,
sa padajućeg menija
Fiskalni printer
, odabrati


Page0004

„

Na panelu Fiskalni printer, neophodno je izvršiti sljedeća podešavanja, označiti opciju

"Mikroelektronika professional
“, te pored navedenog označiti putanju direktorija za print u
folder
C:\temp
i putanju direktorija za log „
C:\temp" “,to je
folder gdje se šalju file-ovi za
printanje i gdje se smještaju log file-ovi. Dodatna podešavanja kao što su
podešavanje prelaska
na ljetno ili zimsko računanje vremena, poreske stope, jedinice mjere, tekst za kupca i naziv trgovine , možete
izvršiti sa tipkama koje se nalaze desno na ovom prozoru.
Opciono možete izabrati upotrebu numeričkih PLU šifri
u zavisnosti od vaših potreba, ukoliko

ova opcija nije uključena, koriste se alfanumeričke šifre, odnosno šifre iz PANTHEON-a.